<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":1,"applicationTime":239,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81893833-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-7bf9e355b46ff060654c148212a35d40cb49b73381f27a9833dcc432fff1c97a.css' rel='stylesheet'>
<script src="https://cdn.rivals.com/production/packs/js/application-470fcb83c674e4c58e70.js"></script>
<link rel="stylesheet" media="screen" href="https://cdn.rivals.com/production/packs/css/application-f351f94b.css" />
<title>RedRaiderSports  -  Texas Tech - 2020 Recruiting Class</title>
<meta content='RedRaiderSports  -  Texas Tech - 2020 Recruiting Class' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-02eb9b5f2c94db113dfb318987ff62b83675833797c26696434b80eefa9d2109.css" />


<script src="https://cdn.rivals.com/production/assets/lib-12381f29bb2a6e1cd6ab2484aa7e729e8f72a6f1457e3a239ac156581f11a919.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-ca9375cb00157a94fb9145cdc52b8a8b269ffbbc606ad5f3cc60aef1d1a15362.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="RI2HE+NYOSY9Vh3aoG4RkvKbh0Ptr+DYlPh1sXy+kfJrehfdDI+/vdSUn+Aea6k/e7YBoGMhE3CvVv4CQBD5AA==" />
<script>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</script>
</script>

<script>
  (function () {
    'use strict';
    angular.module('rivals').factory('baseAppSettings', function () {
  
      var getPremiumIcon = function() {
        return "";
      };
  
      return {
        getPremiumIcon: getPremiumIcon
      };
    });
  }).call(this);
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://texastech.rivals.com/news/texas-tech-2020-recruiting-class?yptr=yahoo?src=rss' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/psbicyxll5qmn2fjkryw' property='og:image'>
<meta content='An overview of the current 2020 recruiting class, including details on the seven new commitments landed this week.' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2019-06-26 16:27:08 -0500' property='article:published_time'>
<meta content='2019-06-26 16:57:03 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "texastech.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='texastech contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .texastech #programming > h1 {
      background-color: #cc0000 !important; } }
  .texastech .wrapper-container .team-colors-line {
    background-color: #000000; }
  .texastech .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #cc0000; }
    .texastech .team-colors-line .color {
      width: 33.33%; }
    .texastech .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .texastech .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .texastech .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .texastech .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .texastech .team-colors-line.header {
      height: 6px; }
  .texastech > header .notification-link .count-container {
    background-color: #cc0000 !important; }
  .texastech > header .wrapper-container {
    background-color: #cc0000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .texastech > header .wrapper-container {
        border-bottom: 6px solid #000000 !important; } }
  .texastech > header .invalid-email-banner {
    background-color: #cc0000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .texastech > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .texastech > header .invalid-email-banner a:hover {
      color: #000000; }
  @media screen and (max-width: 767px) {
    .texastech > header .mobile-header {
      background-color: #000000 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .texastech > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .texastech > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .texastech > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .texastech > header .nav-row > ul,
    .texastech > header .third-nav {
      background-color: white !important; }
    .texastech > header .dropdown-toggle > i.fa {
      color: #cc0000 !important; } }
  .texastech > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #cc0000; }
  
  .site-primary-font-color {
    color: #cc0000; }
  
  .site-primary-background-color {
    background-color: #cc0000; }
  
  .site-secondary-font-color {
    color: #000000; }
  
  .site-secondary-background-color {
    background-color: #000000; }
  
  .team-background-image {
    background-image: linear-gradient(rgba(204, 0, 0, 0.4), rgba(204, 0, 0, 0.4)), url();
    background-repeat: no-repeat;
    background-position: center; }
  
  :root {
    --primary-color: #cc0000;
    --secondary-color: #000000;
    --accent-color: #cc0000;
    --button-color: #cc0000; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init(false)' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Texas Tech" class="site-header" ng-class="ctrl.teamSite ? &quot;team&quot; : &quot;no-team&quot;" href="https://texastech.rivals.com/"><img src="https://res-1.cloudinary.com/rivals/image/upload/qeg5xjtywmdolgnwvctm" alt="Qeg5xjtywmdolgnwvctm" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span class='upsell-text'>
            Join the team!
          </span>
          <a ng-href='{{ ctrl.subscribePath }}'>
            Subscribe
          </a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://texastech.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;texastech&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://texastech.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;texastech&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733154,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Texas Tech - 2020 Recruiting Class"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='RedRaiderSports' name='twitter:site'>
<meta content='Texas Tech - 2020 Recruiting Class' name='twitter:title'>
<meta content='An overview of the current 2020 recruiting class, including details on the seven new commitments landed this week.' name='twitter:description'>
<meta content='https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/psbicyxll5qmn2fjkryw' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":143,"legacy_id":1043,"name":"RedRaiderSports","friendly_name":"Texas Tech","annual_discount":null,"subdomain":"texastech","primary_color":"cc0000","secondary_color":"000000","font_color":"ffffff","short_name":"texastech","maple_ncaaf_team_id":86,"maple_ncaaf_endpoint":"ncaaf/teams/tto","maple_ncaab_team_id":592,"maple_ncaab_endpoint":"ncaab/teams/tas","maple_college_id":86,"google_analytics_id":"UA-81893833-1"}, true, 166, nil, {"id":97,"primary_color":"cc0000","secondary_color":"000000","font_color":"ffffff","commitment_module_football":true,"rivals_module_football":true,"header_name":"","header_logo_cloudinary":"qeg5xjtywmdolgnwvctm","mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-81893833-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":true,"other_content":true,"site_id":143,"created_at":"2016-11-23T13:38:43.496-06:00","updated_at":"2019-01-14T19:00:03.382-06:00","max_trending_articles":6,"enrichments":[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":2},{"active":false,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":null},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3},{"active":false,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"FanFuturecastLeaderboard","football":null,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"message_board_link_url":"https://texastech.forums.rivals.com","scoreboard_scores_id":null,"scoreboard_photos_id":null,"aol_player_id":"5964f6ca8c08e06b62c37931","aol_company_id":"595e9fbb2a30cb7ee3e5395a","ad_frequency":5,"display_twitter_follow":false,"display_fb_follow":false,"follow_twitter_handle":null,"follow_fb_handle":null,"forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":7,"schedule_header_on":true,"promo_popup_on":false,"facebook_developer_id":null,"customized_tos":[],"show_survey_popup":false,"survey_popup_link":null,"header_bottom_border_style":"solid","premium_icon_url":null,"customized_upsell_banner_text":null},&#x000A;"5964f6ca8c08e06b62c37931", "595e9fbb2a30cb7ee3e5395a", "rivals", 15000, false, {"id":642,"user_id":1938957,"site_id":143,"updated_at":"2017-08-16T08:51:02.136-05:00","publisher_name":"Matt Clare","first_name":"Matt","last_name":"Clare","site_title":"Recruiting Analyst","bio":"I write about recruiting and tell stories, been in the game for five years. Thanks for reading, please @ me with any questions because this is all intended to be interactive.","twitter_handle":"MattClareRivals","image_url":"https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_author_bio/lucrruuqx7tgeqt58or2","publisher_name_and_title":"Matt Clare, Recruiting Analyst","site_name":"RedRaiderSports","site_short_name":"texastech","has_edited_profile":true})'>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='upsell-forecast-banner' ng-cloak='true'>
<rv-user-forecast-banner class='forecast-banner' upsell='true'></rv-user-forecast-banner>
</div>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' premium_icon='null' profile_page='false' referral_code='referralCode' team='false'></rv-news-ticker>
</div>

<rv-custom-ad ad='{"id":252,"image_id":1910453,"url":"https://www.wolfdiamonds.com/","position":1,"site_id":143,"created_at":"2017-07-02T18:28:51.903-05:00","updated_at":"2017-07-02T18:28:51.903-05:00","image_url":"https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/reud5awc0xbyohndpfc1"}' class='ad-one'></rv-custom-ad>

<rv-message-boards ad-referer='https://texastech.rivals.com/news/texas-tech-2020-recruiting-class?yptr=yahoo?src=rss' base-api-url='https://texastech.forums.rivals.com/' homepage='false' message-board-url='https://texastech.forums.rivals.com' pub-ad='null' size='size' space-id='2022733154' subscribed-user='subscribedUser'></rv-message-boards>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://texastech.rivals.com/news/texas-tech-2020-recruiting-class/printable' site-name='RedRaiderSports'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2019-06-26 16:27:08 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2055505/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Texas Tech - 2020 Recruiting Class</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<img class='circle-img' src='https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_author_bio/lucrruuqx7tgeqt58or2'>
<span>
<span class='author-name'>
Matt Clare
&bull;
</span>
<span class='type-sm'>RedRaiderSports</span>
<div class='type-sm'>
<a href='//twitter.com/MattClareRivals' target='_blank'>@MattClareRivals</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='author-name'>Recruiting Analyst</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/MattClareRivals'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>
I write about recruiting and tell stories, been in the game for five years. Thanks for reading, please @ me with any questions because this is all intended to be interactive.
</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p><a href="https://texastech.forums.rivals.com/forums/inside-the-double-t.20/">Inside The Double T </a>| <a href="https://texastech.rivals.com/commitments/football/2020">2020 Commitment List</a><br></p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/psbicyxll5qmn2fjkryw','https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto/psbicyxll5qmn2fjkryw')">
<div class='blurred-image image-with-caption'>
<div class='background' style='background-image: url(https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/psbicyxll5qmn2fjkryw)'></div>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img src="https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/psbicyxll5qmn2fjkryw" alt="Psbicyxll5qmn2fjkryw" />
<div class='zoom-image'></div>
</div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>New head coach Matt Wells welcoming the members of the 2019 recruiting class to campus</figcaption>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>Matt Wells and his coaching staff have added seven (7) new verbal commitments to the 2020 recruiting class over the past week.</p><p>After hosting 20-plus prospects for official and unofficial visits in one week, this new Texas Tech coaching staff closed on some top targets and some of the visitors are likely to join the recruiting class later this summer or later in the process.</p><p>The 2020 recruiting class now lists 10 verbal commitments, good for the <a href="https://n.rivals.com/team_rankings/2020/all-teams/football">No. 55 ranked class in the nation</a> and the <a href="https://n.rivals.com/team_rankings/2020/big12/football">No. 9 ranked class in the Big 12 Conference</a>. For now, the amount of commitments for some programs is pushing them ahead of the Red Raiders, but when filtered by the average star ranking per class Texas Tech holds the No. 7 class in the Big 12 Conference.</p><p>-The class features four (4) commitments listed on the <a href="https://rivals.com/state_rankings/2020/texas">Rivals.com Texas Top 150</a> for the 2020 class</p><p>-The class features seven (7) prospects on offense and three (3) on defense<br></p><p>-All 10 commitments are from the state of Texas, the only exception being Donovan Smith who recently moved to West Texas from Nevada</p><p>-The class currently holds one (1) four-star prospect, seven (7) three-star prospects, one (1) two-star prospect and one (1) unrated prospect<br></p><p>Here is a quick overview of the current <a href="https://texastech.rivals.com/commitments/football/2020">Texas Tech 2020 recruiting class</a>, listed by order of commitment announcement from the first addition back in February to the latest addition earlier this week.<br></p>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='206651'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Committed: February 25th, 2019<br></p><p>Smith played wide receiver the past few seasons at Bishop Gorman in Las Vegas, but the son of new running backs coach DeAndre Smith finished his junior year and is moving with the family to West Texas. He is planning to enroll at Frenship High School for the fall and is expected to play quarterback for the Tigers.</p><p>Rated as a 5.4 two-star prospect, the 6-foot-4, 195-pound quarterback prospect chose the Red Raiders over offers from Nevada, San Diego State and Utah State.<br></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">I want to thank <a href="https://twitter.com/TTUCoachWells?ref_src=twsrc%5Etfw">@TTUCoachWells</a> and <a href="https://twitter.com/CoachYost?ref_src=twsrc%5Etfw">@CoachYost</a>  for believing in me from the jump as a freshman. Thank you to my family and coaches for helping me throughout my career so far. After a great weekend at Texas Tech, I’m excited to say I’m going to be a Red Raider‼️🔴⚫️ <a href="https://twitter.com/hashtag/%C5%A620?src=hash&amp;ref_src=twsrc%5Etfw">#Ŧ20</a> <a href="https://twitter.com/hashtag/WreckEm?src=hash&amp;ref_src=twsrc%5Etfw">#WreckEm</a> <a href="https://t.co/JzvTaRV4Te">pic.twitter.com/JzvTaRV4Te</a></p>&mdash; Donovan Smith | 7 (@SmittyJawns) <a href="https://twitter.com/SmittyJawns/status/1100226537746358272?ref_src=twsrc%5Etfw">February 26, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='220972'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Committed: May 12th, 2019</p><p>Rogers committed after taking an unofficial visit to the South Plains for the program's junior day event. He recently took his official visit to Texas Tech and <a href="https://texastech.rivals.com/news/ol-caleb-rogers-all-in-with-texas-tech">recapped the experience with our team</a>. <br></p><p>Rated as a 5.5. three-star prospect, the 6-foot-4, 275-pound tackle prospect chose the Red Raiders over offers from Georgia Tech, New Mexico, William &amp; Mary, Louisiana Monroe and Arkansas State.<br></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">H O M E🌹I’m committed.... <a href="https://t.co/IXMeNawFD4">pic.twitter.com/IXMeNawFD4</a></p>&mdash; cr⁷² (@calebrogers72) <a href="https://twitter.com/calebrogers72/status/1127604888840617984?ref_src=twsrc%5Etfw">May 12, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='202619'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Committed: June 3rd, 2019</p><p>Davis unofficially visited for the program's first junior day event and waited until the school year ended to make his commitment. He recently took his official visit to Texas Tech this past weekend and our team is working to get feedback from Davis.</p><p>Rated a 5.6 three-star prospect, the 6-foot-1, 160-pound safety holds 16 total offers and chose the Red Raiders over offers from Colorado, Arizona, Houston, Georgia Tech, Illinois, Kansas, Purdue and several others.<br></p><p>Davis is listed as the No. 117 overall prospect on the <a href="https://rivals.com/state_rankings/2020/texas">Rivals.com Texas Top 150</a> for the 2020 class.<br></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Proud to announce my Commitment to Texas Tech University <a href="https://twitter.com/CoachKerryCooks?ref_src=twsrc%5Etfw">@CoachKerryCooks</a> <a href="https://twitter.com/TTUCoachWells?ref_src=twsrc%5Etfw">@TTUCoachWells</a> <a href="https://twitter.com/hashtag/RedRaiders?src=hash&amp;ref_src=twsrc%5Etfw">#RedRaiders</a> <a href="https://twitter.com/hashtag/GunsUp?src=hash&amp;ref_src=twsrc%5Etfw">#GunsUp</a> <a href="https://t.co/3Prlt0tiqC">pic.twitter.com/3Prlt0tiqC</a></p>&mdash; JonJon Davis (@Jonathansoc13) <a href="https://twitter.com/Jonathansoc13/status/1135743681804341249?ref_src=twsrc%5Etfw">June 4, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='239241'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Committed: June 20th, 2019</p><p>Anokwuru <a href="https://n.rivals.com/news/texas-tech-feels-like-home-for-de-clinton-anokwuru">committed to the Red Raiders</a> shortly after receiving his scholarship offer. The coaches hosted an on-campus camp and the three-star defensive end impressed the Texas Tech coaching staff.</p><p>Rated a 5.5. three-star prospect, the 6-foot-3, 235-pound defensive end prospect holds 12 total offers and chose the Red Raiders over offers from Army, Louisiana Tech, Navy, SMU and several others.<br></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Burden lifted‼️<a href="https://twitter.com/hashtag/%C5%A620?src=hash&amp;ref_src=twsrc%5Etfw">#Ŧ20</a> <a href="https://twitter.com/hashtag/WreckEm?src=hash&amp;ref_src=twsrc%5Etfw">#WreckEm</a> <a href="https://twitter.com/hashtag/GunsUp?src=hash&amp;ref_src=twsrc%5Etfw">#GunsUp</a> 🔴⚫️🔴👆🏾 <a href="https://t.co/Fa8Rwg4jpr">pic.twitter.com/Fa8Rwg4jpr</a></p>&mdash; Mr Skywalker🕺🏾 (@igboboy_clinton) <a href="https://twitter.com/igboboy_clinton/status/1141885059856850945?ref_src=twsrc%5Etfw">June 21, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='190506'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Committed: June 22nd, 2019</p><p>Brooks was a longtime target for the Texas Tech coaching staff and officially visited campus early last week. He had the opportunity to spend a lot of time with the coaches and players during his visit, <a href="https://n.rivals.com/news/rb-tahj-brooks-excited-to-be-a-red-raider">solidifying his decision to commit to the Red Raiders</a>.</p><p>Rated a 5.7 three-star prospect, the 5-foot-11, 218-pound back holds 22 total offers and chose the Red Raiders over offers from Arkansas, Cal, Duke, Arizona, Georgia Tech, Iowa State, Minnesota, Kansas State, Missouri, TCU, Vanderbilt and several others. <br></p><p>Brooks is listed as the No. 69 overall prospect on the <a href="https://rivals.com/state_rankings/2020/texas">Rivals.com Texas Top 150</a> for the 2020 class.<br></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">They Say , Home Where The Heart Is ❤️...... I AM 1000% COMMITTED TO TEXAS TECH UNIVERSITY ❤️🖤 <a href="https://twitter.com/hashtag/FeedYourFamily?src=hash&amp;ref_src=twsrc%5Etfw">#FeedYourFamily</a> <a href="https://twitter.com/hashtag/WreckEm?src=hash&amp;ref_src=twsrc%5Etfw">#WreckEm</a> <a href="https://twitter.com/hashtag/%C5%A620?src=hash&amp;ref_src=twsrc%5Etfw">#Ŧ20</a> <a href="https://twitter.com/hashtag/CommitToTexasTech?src=hash&amp;ref_src=twsrc%5Etfw">#CommitToTexasTech</a> <a href="https://twitter.com/coachDLSmith1?ref_src=twsrc%5Etfw">@coachDLSmith1</a> <a href="https://twitter.com/TTUCoachWells?ref_src=twsrc%5Etfw">@TTUCoachWells</a> <a href="https://twitter.com/CoachFarmerTTU?ref_src=twsrc%5Etfw">@CoachFarmerTTU</a> <a href="https://t.co/JZzyuUdls7">pic.twitter.com/JZzyuUdls7</a></p>&mdash; 𝕿𝖆𝖍𝖏 𝕭𝖗𝖔𝖔𝖐𝖘 🐎 (@just_tahj) <a href="https://twitter.com/just_tahj/status/1142553140887035904?ref_src=twsrc%5Etfw">June 22, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='206308'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Committed: June 22nd, 2019</p><p>Polk released a Top 4 list of schools in late May that included Texas Tech, Arkansas, Baylor and Arizona. The coaches only offered Polk a few months ago, then got him onto campus for the official visit and <a href="https://n.rivals.com/news/commitment-analysis-four-star-ja-lynn">closed the deal during the visit</a>.</p><p>Rated a 5.8 four-star prospect, the 6-foot-3, 185-pound receiver holds 17 total offers and chose the Red Raiders over offers from Baylor, Arkansas, Arizona, Houston, Kansas, Minnesota, Kansas State, Illinois and several others.</p><p>Polk is listed as the No. 46 overall prospect on the <a href="https://rivals.com/state_rankings/2020/texas">Rivals.com Texas Top 150</a> for the 2020 class.<br></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">I’m 1000% committed. Thank God. Thank you Momma. <a href="https://twitter.com/hashtag/GunsUp?src=hash&amp;ref_src=twsrc%5Etfw">#GunsUp</a>⚫️🔴 <a href="https://t.co/ST3oMyNPRb">pic.twitter.com/ST3oMyNPRb</a></p>&mdash; MONSTERP (@jpolk_22) <a href="https://twitter.com/jpolk_22/status/1142589830381080578?ref_src=twsrc%5Etfw">June 23, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='226318'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Committed: June 22nd, 2019</p><p>Sparkman added an offer from the Texas Tech coaches in late April and officially visited campus this weekend, where he announced his <a href="https://n.rivals.com/news/sparkman-loved-lubbock-talks-ttu-commitment">commitment to the Red Raiders while still on campus</a>.</p><p>Rated a 5.5 three-star prospect, the 6-foot-4, 200-pound receiver holds 14 total offers and chose the Red Raiders over offers from Arkansas, Iowa State, Kansas, Missouri, Kansas State and several others.<br></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">I’m 1000% committed. Thank God. Thank you Lord🙌🏽 <a href="https://twitter.com/hashtag/GunsUp?src=hash&amp;ref_src=twsrc%5Etfw">#GunsUp</a>⚫️🔴 <a href="https://t.co/fK5t5Ig7CT">pic.twitter.com/fK5t5Ig7CT</a></p>&mdash; JJ (@JJ_spark12) <a href="https://twitter.com/JJ_spark12/status/1142607679015280640?ref_src=twsrc%5Etfw">June 23, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='220876'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Committed: June 22nd, 2019</p><p>Bright was a longtime target for the Texas Tech coaching staff and once his state test scores came back with qualifying scores, the three-star prospect wasted no time scheduling his official visit and <a href="https://n.rivals.com/news/bright-sees-the-fit-at-texas-tech">committing to the Red Raiders</a>.</p><p>Rated a 5.6 three-star prospect, the 5-foot-8, 164-pound wide receiver holds 23 total offers and chose the Red Raiders over offers from Baylor, Arkansas, Colorado, Kansas, SMU, Oklahoma State, Nebraska, Purdue, Missouri, Utah, Washington State and several others. <br></p><p>Bright is listed as the No. 111 overall prospect on the <a href="https://rivals.com/state_rankings/2020/texas">Rivals.com Texas Top 150</a> for the 2020 class.<br></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">just turned a dream into reality 🌹 <a href="https://twitter.com/hashtag/WreckEm?src=hash&amp;ref_src=twsrc%5Etfw">#WreckEm</a> <a href="https://twitter.com/hashtag/%C5%A620?src=hash&amp;ref_src=twsrc%5Etfw">#Ŧ20</a><br>🎥 : <a href="https://twitter.com/Centex_Recruits?ref_src=twsrc%5Etfw">@Centex_Recruits</a> <a href="https://t.co/8rKPfQbO3t">pic.twitter.com/8rKPfQbO3t</a></p>&mdash; br1ght ⚡️ (@QuinBright) <a href="https://twitter.com/QuinBright/status/1142612124189024261?ref_src=twsrc%5Etfw">June 23, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='236774'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Committed: June 23rd, 2019</p><p>Moore received his offer from the Texas Tech coaches in early May and officially visited campus this past weekend. The three-star prospect <a href="https://n.rivals.com/news/moore-loves-the-program-at-ttu">announced his commitment to the Red Raiders</a> only a day after returning home to the Houston area. <br></p><p>Rated a 5.5. three-star prospect, the 6-foot-6, 270-pound lineman holds 15 total offers and chose the Red Raiders over offers from Georgia Tech, Houston, Kansas, SMU and several others.<br></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">COMMITTED ‼️ <a href="https://twitter.com/hashtag/%C5%A620?src=hash&amp;ref_src=twsrc%5Etfw">#Ŧ20</a> <a href="https://t.co/rPvINOZtcE">pic.twitter.com/rPvINOZtcE</a></p>&mdash; Larry Moore 7️⃣4️⃣ (@_LMOORE74) <a href="https://twitter.com/_LMOORE74/status/1142822576416317441?ref_src=twsrc%5Etfw">June 23, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='237119'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Committed: June 24th, 2019</p><p>Dabon received an offer from the Texas Tech coaches in late May and officially visited campus this past weekend. He waited a few days after returning home to the Houston area before <a href="https://n.rivals.com/news/a-winning-mindset-won-over-dabon">announcing his commitment to the Red Raiders</a>. <br></p><p>Currently unrated, the 6-foot-2, 182-pound safety holds 15 total offers and chose the Red Raiders over offers from Missouri, Houston, UTSA, Tulsa, North Texas and several others.<br></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">BREAKING NEWS.....After a great Official Visit..I would like to announce that I will be committing to Texas Tech University👆🔴 TTech will be getting my all.. and I will leave my mark there <a href="https://twitter.com/hashtag/WreckEm?src=hash&amp;ref_src=twsrc%5Etfw">#WreckEm</a> <a href="https://twitter.com/hashtag/GunsUp?src=hash&amp;ref_src=twsrc%5Etfw">#GunsUp</a> MARK MY WORDS!!! I want to thank God, my Mom,Family, and Coaches <a href="https://t.co/N7n2oVGA1u">pic.twitter.com/N7n2oVGA1u</a></p>&mdash; Jay Dabon (@vaun28_) <a href="https://twitter.com/vaun28_/status/1143247851981541378?ref_src=twsrc%5Etfw">June 24, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>The dead period is here, but the coaching staff is expecting decisions from another handful of recent 2020 targets and visitors. Stay tuned to <i>RedRaiderSports</i> for the latest 2020 recruiting updates.</p><p>Not a member? Sign up today for complete coverage of Texas Tech sports and recruiting.<br></p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/i67oa5yaboftkibkivgo','https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto/i67oa5yaboftkibkivgo')">
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/i67oa5yaboftkibkivgo)'></div>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/i67oa5yaboftkibkivgo" alt="I67oa5yaboftkibkivgo" />
<div class='zoom-image'></div>
</div>
</div>
</figure>
</div>
<div class='text-center'>
<rv-share-links print-url='https://texastech.rivals.com/news/texas-tech-2020-recruiting-class/printable' site-name='RedRaiderSports'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2018' ncaaf-schedule-year='2019' site='{"id":143,"legacy_id":1043,"name":"RedRaiderSports","friendly_name":"Texas Tech","annual_discount":null,"subdomain":"texastech","primary_color":"cc0000","secondary_color":"000000","font_color":"ffffff","short_name":"texastech","maple_ncaaf_team_id":86,"maple_ncaaf_endpoint":"ncaaf/teams/tto","maple_ncaab_team_id":592,"maple_ncaab_endpoint":"ncaab/teams/tas","maple_college_id":86,"google_analytics_id":"UA-81893833-1"}' twitter-feed='{"id":142,"site_id":143,"handle":"RedRaiderSports","list_name":"","created_at":"2016-02-01T12:25:29.394-06:00","updated_at":"2016-08-02T08:12:11.736-05:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://texastech.rivals.com/news/texas-tech-2020-recruiting-class/printable' site-name='RedRaiderSports'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733154', 'https://texastech.rivals.com/news/texas-tech-2020-recruiting-class?yptr=yahoo?src=rss');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Texas Tech - 2020 Recruiting Class";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div ng-controller='googleTagManagerController as ctrl' ng-init='ctrl.init("texastech", 2055505, null)'>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
<noscript>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<rv-custom-ad ad='{"id":252,"image_id":1910453,"url":"https://www.wolfdiamonds.com/","position":1,"site_id":143,"created_at":"2017-07-02T18:28:51.903-05:00","updated_at":"2017-07-02T18:28:51.903-05:00","image_url":"https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/reud5awc0xbyohndpfc1"}' class='ad-one'></rv-custom-ad>
</div>
</div>

</div>
</main>
<div data-react-class="Footer/container" data-react-props="{}"></div>

</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733154",
    c7: "https://texastech.rivals.com/news/texas-tech-2020-recruiting-class?yptr=yahoo?src=rss"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Ftexastech.rivals.com%2Fnews%2Ftexas-tech-2020-recruiting-class%3Fyptr%3Dyahoo%3Fsrc%3Drss&c5=2022733154&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
