<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":2,"applicationTime":185,"agent":""}</script>
<script type="text/javascript">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</script>
<script>
  var googleAnalyticsId = "UA-81893833-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>RedRaiderSports.com  -  Watson feels like Texas Tech could be a perfect situation</title>
<meta content='RedRaiderSports.com  -  Watson feels like Texas Tech could be a perfect situation' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-2eada6c4ef76b32c1d573f4c7ad6fd2ed16b2c21706319015a98c50ca76b4e2e.css" />

<script src="https://cdn.rivals.com/production/assets/application-bd8e0400049933d7d82b6800a27663d3f82104735ca93ffa4c021e578eb2a73b.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="AVUgRzwZz8VhqarE3QFBeMO4RWfuvtWThK440/y4wiAUKWBT0cryApfmOO1UiHiAYKPjwF+HtbYGesbZ6cZKpg==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://texastech.rivals.com/news/watson-feels-like-texas-tech-could-be-a-perfect-situation' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/wf4rdgujar0v3pmpk7yp' property='og:image'>
<meta content='Cal grad transfer running back Tre Watson shares the scoop on how his visit to Texas Tech went over the weekend.' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-04-18 09:50:42 -0500' property='article:published_time'>
<meta content='2018-04-18 09:50:43 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "texastech.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='texastech contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .texastech #programming > h1 {
      background-color: #cc0000 !important; } }
  .texastech > header .notification-link .count-container {
    background-color: #cc0000 !important; }
  .texastech > header .wrapper-container {
    background-color: #cc0000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .texastech > header .wrapper-container {
        border-bottom: 5px solid #000000 !important; } }
  .texastech > header .invalid-email-banner {
    background-color: #cc0000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .texastech > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .texastech > header .invalid-email-banner a:hover {
      color: #000000; }
  @media screen and (max-width: 767px) {
    .texastech > header .mobile-header {
      background-color: #000000 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .texastech > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .texastech > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .texastech > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .texastech > header .nav-row > ul,
    .texastech > header .third-nav {
      background-color: white !important; }
    .texastech > header .dropdown-toggle > i.fa {
      color: #cc0000 !important; } }
  .texastech > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #cc0000; }
  
  .site-primary-font-color {
    color: #cc0000; }
  
  .site-primary-background-color {
    background-color: #cc0000; }
  
  .site-secondary-font-color {
    color: #000000; }
  
  .site-secondary-background-color {
    background-color: #000000; }
  
  :root {
    --outbrain-primary-color: #cc0000;
    --outbrain-secondary-color: #000000; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Texas Tech" class="school-header" href="//texastech.rivals.com"><img src="https://res-1.cloudinary.com/rivals/image/upload/qeg5xjtywmdolgnwvctm" alt="Qeg5xjtywmdolgnwvctm" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//texastech.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;texastech&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//texastech.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;texastech&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733154,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Watson feels like Texas Tech could be a perfect situation"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='RedRaiderSports' name='twitter:site'>
<meta content='Watson feels like Texas Tech could be a perfect situation' name='twitter:title'>
<meta content='Cal grad transfer running back Tre Watson shares the scoop on how his visit to Texas Tech went over the weekend.' name='twitter:description'>
<meta content='https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/wf4rdgujar0v3pmpk7yp' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1914692,"title":"In-Depth Spring Ball Recap","slug":"in-depth-spring-ball-recap","kind":"premium","site_id":143,"sport":"football","news_type":"team","content_type":"Content::ForumThread","live_at":"2018-04-16T19:28:27.947-05:00","summary":"Will McKay takes a deep dive for a 4000 word recap of everything that happened throughout spring football for Texas Tech","deleted":false,"author_name":"Will McKay","author_title":"Associate Editor","permalink":"https://texastech.rivals.com/news/in-depth-spring-ball-recap","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1914691,"title":"Tech adds Oregon State transfer Collins","slug":"tech-adds-oregon-state-transfer-collins","kind":"premium","site_id":143,"sport":"football","news_type":"team","content_type":"Content::ForumThread","live_at":"2018-04-16T19:25:07.206-05:00","summary":"Texas Tech added Oregon State grad transfer and receiver Seth Collins to the mix on Monday afternoon.","deleted":false,"author_name":"Will McKay","author_title":"Associate Editor","permalink":"https://texastech.rivals.com/news/tech-adds-oregon-state-transfer-collins","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1914623,"title":"Tailgate Express Roundtable","slug":"tailgate-express-roundtable-33","kind":"premium","site_id":143,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-16T15:21:50.667-05:00","summary":"Chris Level and Aaron Dickens recap the weekend that was for Texas Tech in this week&#x0027;s edition of the Roundtable!","deleted":false,"author_name":"Will McKay","author_title":"Associate Editor","permalink":"https://texastech.rivals.com/news/tailgate-express-roundtable-33","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1914398,"title":"McGill earns offer from Tech, loved what he saw on his visit","slug":"mcgill-talks-spring-game-receiving-an-offer-from-tech","kind":"premium","site_id":143,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-16T09:00:00.000-05:00","summary":"Coppell defensive back Jonathan McGill discusses taking in Texas Tech&#x0027;s spring game, receiving an offer and more!","deleted":false,"author_name":"Maitland Rutledge","author_title":"Staff Writer","permalink":"https://texastech.rivals.com/news/mcgill-talks-spring-game-receiving-an-offer-from-tech","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1914332,"title":"Miterko amped to pick up a Big 12 offer while visiting Tech","slug":"miterko-talks-spring-game-and-receiving-an-offer-from-tech","kind":"premium","site_id":143,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-16T08:00:00.000-05:00","summary":"Carlsbad offensive tackle Taylor Miterko discusses attending Texas Tech&#x0027;s spring game and receiving an offer!","deleted":false,"author_name":"Maitland Rutledge","author_title":"Staff Writer","permalink":"https://texastech.rivals.com/news/miterko-talks-spring-game-and-receiving-an-offer-from-tech","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1914143,"title":"THOUGHTS: Run game sticks out in the Spring Game","slug":"thoughts-run-game-sticks-out-in-the-spring-game","kind":"premium","site_id":143,"sport":"football","news_type":"team","content_type":"Content::ForumThread","live_at":"2018-04-14T20:59:10.981-05:00","summary":"Head inside for Will McKay&#x0027;s thoughts from Texas Tech&#x0027;s Saturday night Spring Game in Lubbock.","deleted":false,"author_name":"Will McKay","author_title":"Associate Editor","permalink":"https://texastech.rivals.com/news/thoughts-run-game-sticks-out-in-the-spring-game","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1914083,"title":"LIVE THREAD: Tech holds annual spring game in Lubbock","slug":"live-thread-tech-holds-annual-spring-game-in-lubbock","kind":"premium","site_id":143,"sport":"football","news_type":"team","content_type":"Content::ForumThread","live_at":"2018-04-14T17:44:20.929-05:00","summary":"Head inside for live updates, reaction, and analysis from Texas Tech&#x0027;s spring game tonight. Join in on the discussion!","deleted":false,"author_name":"Will McKay","author_title":"Associate Editor","permalink":"https://texastech.rivals.com/news/live-thread-tech-holds-annual-spring-game-in-lubbock","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1913645,"title":"Culver ready to get back to work for sophomore campaign","slug":"culver-ready-to-get-back-to-work-for-sophomore-campaign","kind":"free","site_id":143,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-13T09:47:09.089-05:00","summary":"The offseason has begun, and Jarrett Culver&#x0027;s already back to work. Get his thoughts on where things stand right here.","deleted":false,"author_name":"Will McKay","author_title":"Associate Editor","permalink":"https://texastech.rivals.com/news/culver-ready-to-get-back-to-work-for-sophomore-campaign","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1913501,"title":"Cardinal&#x0027;s Red Raider Confidential (April 13th)","slug":"cardinal-s-red-raider-confidential-april-13th-","kind":"premium","site_id":143,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-13T08:52:28.307-05:00","summary":"Head inside this week&#x0027;s Red Raider Confidential for \r\n updates from the scrimmage at The Star and more!","deleted":false,"author_name":"Staff","author_title":"RedRaiderSports.com","permalink":"https://texastech.rivals.com/news/cardinal-s-red-raider-confidential-april-13th-","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1913473,"title":"RRS Radio: Gator&#x0027;s Bayou Matador Report","slug":"rrs-radio-gator-s-bayou-matador-report","kind":"premium","site_id":143,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-12T15:54:00.924-05:00","summary":"Head inside as Aaron Dickens and Chris Level answer your questions about all things Texas Tech in the Matador Report.","deleted":false,"author_name":"Will McKay","author_title":"Associate Editor","permalink":"https://texastech.rivals.com/news/rrs-radio-gator-s-bayou-matador-report","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1913385,"title":"Jeffers discusses goals, learning from Allen and more","slug":"jeffers-discusses-goals-learning-from-allen-and-more","kind":"premium","site_id":143,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-12T11:53:12.696-05:00","summary":"Riko Jeffers is entering his sophomore season. Read about what he said going into 2018 with a year under his belt.","deleted":false,"author_name":"Brandon Soliz","author_title":"Staff Writer","permalink":"https://texastech.rivals.com/news/jeffers-discusses-goals-learning-from-allen-and-more","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1913254,"title":"Tarke in talks to visit Texas Tech, impressed by the addition of Owens","slug":"tarke-in-talks-to-visit-texas-tech-talks-addition-of-owens-and-more","kind":"premium","site_id":143,"sport":"basketball","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-12T08:41:52.195-05:00","summary":"The Red Raiders are in pursuit of another transfer. Read more about Anthony Tarke&#x0027;s interest in Texas Tech here!","deleted":false,"author_name":"Brandon Soliz","author_title":"Staff Writer","permalink":"https://texastech.rivals.com/news/tarke-in-talks-to-visit-texas-tech-talks-addition-of-owens-and-more","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1913171,"title":"The Search: Finding Tech&#x0027;s next leading receiver","slug":"the-search-finding-tech-s-next-leading-receiver","kind":"premium","site_id":143,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-11T17:06:08.305-05:00","summary":"Tech&#x0027;s on the search for a new top dog at receiver. Will McKay breaks down the candidates and projected winner.","deleted":false,"author_name":"Will McKay","author_title":"Associate Editor","permalink":"https://texastech.rivals.com/news/the-search-finding-tech-s-next-leading-receiver","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1913144,"title":"Gardner talks Star scrimmage, looking to head back to Lubbock soon","slug":"gardner-talks-star-scrimmage-looking-to-head-back-to-lubbock-soon","kind":"premium","site_id":143,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-11T15:44:04.757-05:00","summary":"Dallas Skyline athlete Velton Gardner talks Texas Tech and what he saw at the scrimmage at The Star.","deleted":false,"author_name":"Ben Golan","author_title":"Staff Writer","permalink":"https://texastech.rivals.com/news/gardner-talks-star-scrimmage-looking-to-head-back-to-lubbock-soon","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1912967,"title":"Wednesday Live Chat","slug":"wednesday-live-chat-1","kind":"premium","site_id":143,"sport":"football","news_type":"team","content_type":"Content::ForumThread","live_at":"2018-04-11T12:02:48.489-05:00","summary":"Will McKay answers all your questions about spring football, basketball recruiting, and baseball&#x0027;s season right here!","deleted":false,"author_name":"Will McKay","author_title":"Associate Editor","permalink":"https://texastech.rivals.com/news/wednesday-live-chat-1","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1912880,"title":"Zeno previews weekend visit to Tech","slug":"zeno-previews-weekend-visit-to-tech","kind":"premium","site_id":143,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-11T09:59:39.537-05:00","summary":"On the practice field this spring, the quarterback battle taking place at Texas Tech is arguably one of the top story","deleted":false,"author_name":"Matt Clare","author_title":"Recruiting Analyst","permalink":"https://texastech.rivals.com/news/zeno-previews-weekend-visit-to-tech","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1912677,"title":"Owens dishes on what sold him to head to Texas Tech","slug":"owens-dishes-on-what-sold-him-to-head-to-texas-tech","kind":"premium","site_id":143,"sport":"basketball","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-10T17:19:57.122-05:00","summary":"Grad transfer forward Tariq Owens dishes on what sold him to head to Texas Tech for his senior season.","deleted":false,"author_name":"Will McKay","author_title":"Associate Editor","permalink":"https://texastech.rivals.com/news/owens-dishes-on-what-sold-him-to-head-to-texas-tech","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1912588,"title":"The Notebook: Frye confident in competition, Brooks at his best and more","slug":"the-notebook-frye-confident-in-competition-brooks-at-his-best-and-more","kind":"premium","site_id":143,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-10T13:15:42.000-05:00","summary":"Texas Tech is down to one practice and a scrimmage. Read what Kingsbury and players had to say about that and more here!","deleted":false,"author_name":"Brandon Soliz","author_title":"Staff Writer","permalink":"https://texastech.rivals.com/news/the-notebook-frye-confident-in-competition-brooks-at-his-best-and-more","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1912503,"title":"Watkins hearing regularly from the Red Raiders","slug":"watkins-hearing-regularly-from-the-red-raiders","kind":"premium","site_id":143,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-10T10:14:57.524-05:00","summary":"Head inside to find out what South Hills RB prospect Anthony Watkins has been hearing from Texas Tech!","deleted":false,"author_name":"Ben Golan","author_title":"Staff Writer","permalink":"https://texastech.rivals.com/news/watkins-hearing-regularly-from-the-red-raiders","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1912402,"title":"Wilson loved scrimmage at The Star, heading back to Lubbock soon","slug":"wilson-talks-attending-tech-scrimmage-in-frisco","kind":"premium","site_id":143,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-10T09:15:30.544-05:00","summary":"Argyle offensive tackle Preston Wilson discusses attending Texas Tech&#x0027;s scrimmage in Frisco and more!","deleted":false,"author_name":"Maitland Rutledge","author_title":"Staff Writer","permalink":"https://texastech.rivals.com/news/wilson-talks-attending-tech-scrimmage-in-frisco","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1912352,"title":"RRS TV: Monday Musings","slug":"rrs-tv-monday-musings-1","kind":"premium","site_id":143,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-09T19:02:28.164-05:00","summary":"Will McKay shares his thoughts from the weekend and previews the week that will be in Tech athletics in Monday Musings.","deleted":false,"author_name":"Will McKay","author_title":"Associate Editor","permalink":"https://texastech.rivals.com/news/rrs-tv-monday-musings-1","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1912292,"title":"Tariq Owens is Tech-bound. What now?","slug":"tariq-owens-is-tech-bound-what-now-","kind":"premium","site_id":143,"sport":"basketball","news_type":"team","content_type":"Content::ForumThread","live_at":"2018-04-09T15:02:00.588-05:00","summary":"St. John&#x0027;s grad transfer Tariq Owens is headed to Texas Tech. Will breaks down what that means and what&#x0027;s next in hoops.","deleted":false,"author_name":"Will McKay","author_title":"Associate Editor","permalink":"https://texastech.rivals.com/news/tariq-owens-is-tech-bound-what-now-","site_name":"RedRaiderSports.com","type":"Content","programming":[],"associated_links":[]}], nil, 143, nil, true); subdomain = &#x0027;texastech&#x0027;; aolPlayerId = &#x0027;5964f6ca8c08e06b62c37931&#x0027;; aolCompanyId = &#x0027;595e9fbb2a30cb7ee3e5395a&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #cc0000'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":252,"image_id":1910453,"url":"https://www.wolfdiamonds.com/","position":1,"site_id":143,"created_at":"2017-07-02T18:28:51.903-05:00","updated_at":"2017-07-02T18:28:51.903-05:00","image_url":"https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/reud5awc0xbyohndpfc1"}' class='ad-one'></rv-custom-ad>

<rv-homepage-forums ad-referer='https://texastech.rivals.com/news/watson-feels-like-texas-tech-could-be-a-perfect-situation' background-color='#cc0000' base-api-url='https://texastech.forums.rivals.com/' homepage='false' message-board-url='texastech.forums.rivals.com' pub-ad='null' size='size' space-id='2022733154' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://texastech.rivals.com/news/watson-feels-like-texas-tech-could-be-a-perfect-situation/printable' site-name='RedRaiderSports.com'></rv-share-links>
</div>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-04-18 09:50:42 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1915211/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Watson feels like Texas Tech could be a perfect situation</h2>
<div class='header-image'><figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/wf4rdgujar0v3pmpk7yp)'></div>
<img src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/wf4rdgujar0v3pmpk7yp" alt="Wf4rdgujar0v3pmpk7yp" />
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'>Getty Images</div>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<img class='circle-img' src='https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_author_bio/aukswmnykvoblmptnqgh'>
<span>
<span class='title-sm'>
Will McKay
&bull;
</span>
<span class='type-sm'>RedRaiderSports.com</span>
<div class='type-sm'>
<a href='//twitter.com/Will_R_McKay' target='_blank'>@Will_R_McKay</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Associate Editor</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/Will_R_McKay'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>
After working in the Lubbock sports media for the last six years, Will has grown into one of the most trusted Texas Tech football, basketball, and baseball insiders in college athletics.
</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='upsell'>
<div class='preview-container'>
<div class='article-preview'></div>
<div class='fade-container'>
<div class='article-fade'></div>
<div class='st__content-block st__content-block--text article-text'>
<p>The grad transfer market has become a normalized part of the college basketball recruiting cycle over the years, and at this point college football isn&#39;t far behind. With an undergraduate degree al...</p>

</div>

</div>
</div>
<div class='upsell-content'>
<div class='row premium-divider'>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
<div class='premium-content col-sm-8 col-xs-12'>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span>Premium Content</span>
</div>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
</div>
<h3 class='upsell-headline'>Subscribe today to read the full article and get everything Rivals has to offer.</h3>
<div class='row buttons'>
<div class='col-xs-24 col-sm-12'>
<div class='subscribe'>
<a class="btn" href="/sign_up?preselected_site_id=143">Subscribe to Rivals</a>
</div>
</div>
<div class='sign-in col-xs-24 col-sm-12'>
<a class="btn" href="/users/sign_in">Sign in</a>
</div>
</div>
<div class='value-props row'>
<ul>
<li class='value-prop fa-before fa-check'>Member-only message boards</li>
<li class='value-prop fa-before fa-check'>Exclusive highlights and recruiting interviews</li>
<li class='value-prop fa-before fa-check'>Exclusive coverage of Rivals Camp Series</li>
<li class='value-prop fa-before fa-check'>Breaking recruiting news</li>
</ul>
</div>
</div>
<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>

</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://texastech.rivals.com/news/watson-feels-like-texas-tech-could-be-a-perfect-situation/printable' site-name='RedRaiderSports.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' site='{"id":143,"legacy_id":1043,"name":"RedRaiderSports.com","friendly_name":"Texas Tech","annual_discount":null,"subdomain":"texastech","primary_color":"cc0000","secondary_color":"000000","font_color":"ffffff","short_name":"texastech","maple_ncaaf_team_id":86,"maple_ncaaf_endpoint":"ncaaf/teams/tto","maple_ncaab_team_id":592,"maple_ncaab_endpoint":"ncaab/teams/tas","maple_college_id":86,"google_analytics_id":"UA-81893833-1"}' twitter-feed='{"id":142,"site_id":143,"handle":"RedRaiderSports","list_name":"","created_at":"2016-02-01T12:25:29.394-06:00","updated_at":"2016-08-02T08:12:11.736-05:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://texastech.rivals.com/news/watson-feels-like-texas-tech-could-be-a-perfect-situation/printable' site-name='RedRaiderSports.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733154', 'https://texastech.rivals.com/news/watson-feels-like-texas-tech-could-be-a-perfect-situation');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Watson feels like Texas Tech could be a perfect situation";
  _sf_async_config.sections = 'content,content-football,content-football-premium,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":252,"image_id":1910453,"url":"https://www.wolfdiamonds.com/","position":1,"site_id":143,"created_at":"2017-07-02T18:28:51.903-05:00","updated_at":"2017-07-02T18:28:51.903-05:00","image_url":"https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/reud5awc0xbyohndpfc1"}' class='ad-one'></rv-custom-ad>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://texastech.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733154",
    c7: "https://texastech.rivals.com/news/watson-feels-like-texas-tech-could-be-a-perfect-situation"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Ftexastech.rivals.com%2Fnews%2Fwatson-feels-like-texas-tech-could-be-a-perfect-situation&c5=2022733154&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
